Page 2 of 2

Re: how to setup and use greaseweazle v4

Posted: Sun Sep 04, 2022 1:28 pm
by Symoon
Hi,

I'm trying to read a 3" disk with my brand new Greaseweazle v4, and unsurprisingly as everytime I'm trying to work with disks, it doesn't work. All I ever get is "Command Failed: GetFluxStatus: No Index", and then nothing.
Either I'm doing something wrong, either I'm cursed with disks and will end up sending everything to the bin some time ^^

If not mistaken, I've bee using the same tool and setting than Hutch. The drive is on (the led is constantly bright) and seems to keep rotating, from the moment I plug it on. I tried with drive 0, 1, A and B to be sure I hadn't made some configuration mistake.
FluxMyFluffyFloppy.png
I read somewhere this indicated I likely plugged the floppy cable upside down, so changed it (as it's not clearly indicated on the card and my cable has no plastic-thing-to-prevent-from-plugging-upside-down), and got a big BEEEEEEP which made me think it was probably not the right correction ^^

I'm done with it for the weekend, being slightly fed up with disks and the constant resulting waste of time ;) But if anyone has any idea, or any succes with that hardware and know of traps to avoid, I'd be glad to read!
Thanks in advance.
PS: I could partially read the floppy disk I want to transfer, with the floppy drive I'm using, on a real Oric. So both are "working" (with errors of course ;) )

Re: how to setup and use greaseweazle v4

Posted: Mon Sep 05, 2022 2:56 pm
by Dbug
I've still not tried my Greaseweazle, it's on my very long list of things to do :roll:

Re: how to setup and use greaseweazle v4

Posted: Mon Sep 05, 2022 3:07 pm
by Symoon
When I have the time / nerve to go back at it, I will try with a 3.5 floppy. Maybe it's more standard and if it works, that may indicate a drive incompatibility/misconfiguration.

Re: how to setup and use greaseweazle v4

Posted: Mon Sep 05, 2022 4:42 pm
by kailokyra
Are you confident about the ribbon cable you're using (and/or adapter to floppy 26 to 34 pin format), and the pinout ?

Are you also sure of your power supply and power connector pinout ? (On Amstrad CPC plus disc drives 5V and 12V are reversed for example, I assume it's the same for drives of other origins)

Re: how to setup and use greaseweazle v4

Posted: Mon Sep 05, 2022 6:30 pm
by Symoon
Thanks kailokyra for the relpy. Actually... Success!

The problem was the following:
1- I actually had the ribbon plugged upside-down, resulting the drive was always rotating
2- by changing it, I had the BEEEEEEEP again... Its cause ? Well, the drive was set up as drive B, and my drive A was plugged but... Unpowered!

Didn't know an unpowered drive could have this effect.
Feeling better!

Re: how to setup and use greaseweazle v4

Posted: Tue Sep 20, 2022 10:35 pm
by Steve M
USB provides 5V power. You can run 3.5" drives from it with no extra power suply. 3" drives need the 12V and 5V so need external power supply.

Re: how to setup and use greaseweazle v4

Posted: Sun Nov 20, 2022 4:54 pm
by coco.oric
After keeping my greaseweazle in my stock, i've tried to use it.
I've succeeded in make a backup from my amiga disk ; but i did'nt succeeded yet with a st disk.

If somebody knowns a tip, or may be i forgot something. I'll search ..
Then i'll try to connect an oric drive (as well i'll try with my orix base)