Connectivity problems (again)

In this forum you can write about anything that does not fit in other forums.
This includes generic Oric talkings and things that are totaly unrelated but want to share with people here :)
User avatar
HigashiJun
Flying Officer
Posts: 145
Joined: Tue Dec 10, 2019 9:29 am
Location: Tokyo (Japan)

Re: Connectivity problems (again)

Post by HigashiJun »

New feedback: everything seems OK for me since yesterday. I logged in several times without any glitches.
HigashiJun

User avatar
Dbug
Site Admin
Posts: 3399
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug »

Hmm, I guess that's good, just wish I knew why!

From the Apache logs, the only things remaining are the DokuWiki errors:
Declaration of action_plugin_importoldchangelog::register(&$controller) should be compatible with DokuWiki_Action_Plugin::register(Doku_Event_Handler $controller) in /media/disk-1/www/www_wiki/lib/plugins/importoldchangelog/action.php on line 8
PHP Warning: Declaration of action_plugin_importoldindex::register(&$controller) should be compatible with DokuWiki_Action_Plugin::register(Doku_Event_Handler $controller) in /media/disk-1/www/www_wiki/lib/plugins/importoldindex/action.php on line 0

User avatar
HigashiJun
Flying Officer
Posts: 145
Joined: Tue Dec 10, 2019 9:29 am
Location: Tokyo (Japan)

Re: Connectivity problems (again)

Post by HigashiJun »

Sorry Dbug to bring bad news, but it was a pain again to connect now (18:30 in Japan, 10:30 in France)...

Everything was OK during 2 days until now. :(

What's going on ?
HigashiJun

User avatar
Symoon
Archivist
Posts: 1889
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon »

11:40 (France) : everything seems perfect with "In total there are 27 users online" Instead of the 200-300 that were permanently listed before.

11h41: trying to post the above, got timed out.
When I reached back the forum (still 11h41), there were more than 100 users reported.

11h42: still lots of timeouts and 219 users reported.

Looks like something/someone is flooding the forum? Or could it be our actions that do something that creates fake users?

User avatar
ibisum
Wing Commander
Posts: 1318
Joined: Fri Apr 03, 2009 8:56 am
Location: Vienna, Austria
Contact:

Re: Connectivity problems (again)

Post by ibisum »

Seems to me more like a DDOS is going on .. I've seen intermittent responses like the others, and occasionally after you do something to the server it gets much better, performance-wise, but then when you leave it alone for an hour or so, it all goes pear shaped.

User avatar
Dbug
Site Admin
Posts: 3399
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug »

If it's DDOSS, possibly I will have to see if I can apply the exclusion list on the router itself instead of the webserver.

In the meantime, I got myself a new drive for the server (been out buying it in a shop, trying to not get caught by zombies roaming around Oslo city center) and I'll try to do some maintenance on the machine this evening, so expect some down time.

User avatar
Dbug
Site Admin
Posts: 3399
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug »

I updated the .htaccess ban list with the latest from https://www.wizcrafts.net/chinese-blocklist_2_4.html

We will see if that somewhat helps.

User avatar
ibisum
Wing Commander
Posts: 1318
Joined: Fri Apr 03, 2009 8:56 am
Location: Vienna, Austria
Contact:

Re: Connectivity problems (again)

Post by ibisum »

Certainly seems very snappy now!

User avatar
HigashiJun
Flying Officer
Posts: 145
Joined: Tue Dec 10, 2019 9:29 am
Location: Tokyo (Japan)

Re: Connectivity problems (again)

Post by HigashiJun »

Great, everything seems alright now !

:D
HigashiJun

User avatar
coco.oric
Squad Leader
Posts: 576
Joined: Tue Aug 11, 2009 9:50 am
Location: North of France
Contact:

Re: Connectivity problems (again)

Post by coco.oric »

Seems quicker as my oric-1
Thanks
coco.oric as DidierV, CEO Member
Historic owner of Oric, Apple II, Atari ST, Amiga

User avatar
Symoon
Archivist
Posts: 1889
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon »

Absolutely perfect now.
And just check the amount of users on the main page: 10 times less!
Thanks!

User avatar
Dbug
Site Admin
Posts: 3399
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug »

Looks like this list of IPs will have to be updated regularly, but that seems to have an effect:
phpbb_accessed_pages.png
phpbb_accessed_pages.png (30.87 KiB) Viewed 2191 times
phpbb_access_count.png
phpbb_access_count.png (10.6 KiB) Viewed 2191 times

User avatar
Dbug
Site Admin
Posts: 3399
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug »

Since the last remaining warnings on the error.log were related to dokuwiki, I removed the remnants of the two plugins "importoldindex" and "importoldchangelog", for all I see, the wiki is still working, but please poke me if you notice anything wrong.

I can now clearly see that some people are trying to find hacks in the server:
- script '/var/www/www.defence-force.org/computing/demo/sc ... -login.php' not found or unable to stat, referer: http://next.atari.org/wp-login.php
- script '/var/www/defence-force.com/wp-login.php' not found or unable to stat
- some attempts at finding a "php sysinfo"

etc...

User avatar
mikeb
Flight Lieutenant
Posts: 256
Joined: Wed Sep 05, 2018 8:03 pm
Location: West Midlands, UK
Contact:

Re: Connectivity problems (again)

Post by mikeb »

It's back ...

In total there are 238 users online :: 2 registered, 0 hidden and 236 guests (based on users active over the past 5 minutes)

Me: 90.155. 95.134

Getting:
Connection to 37.191.243.240 Failed
(110) Connection timed out

Sun May 3 21:52:49 BST 2020
to
Sun May 3 22:09:41 BST 2020

User avatar
HigashiJun
Flying Officer
Posts: 145
Joined: Tue Dec 10, 2019 9:29 am
Location: Tokyo (Japan)

Re: Connectivity problems (again)

Post by HigashiJun »

Yup, same problem here...

A pain to get logged-in and post something.

Hope Dbug could resolve this issue soon.

Cheers.
HigashiJun

Post Reply