Experimental very fast tape loading

Anything related to the tools Tap2Wav, Tap2CD, Tap2Dsk, Sedoric Disc Manager, Tape Header Creator, WriteDsk, and generaly speaking tools related to the management of Oric data files and devices.
User avatar
Chema
Game master
Posts: 2201
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: Experimental very fast tape loading

Post by Chema » Tue May 08, 2018 1:52 pm

Indeed it was there in the Spam folder...

Can't imagine why. Must be related to your email server.

In any case I got the zip file... I will test as soon as I have time to put my Oric setup to work!

User avatar
Symoon
Archivist
Posts: 1316
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Experimental very fast tape loading

Post by Symoon » Wed May 09, 2018 6:56 pm

Thanks Chema.

Anyone willing to test, here's still the same HIRES picture.
Do HIRES first ! :wink:

One has the loader at standard speed, the other at F16 speed. I'm interested to know if both work for all!
Thanks :)
ship_novalight_1.1g.zip
(21.3 KiB) Downloaded 13 times

User avatar
Symoon
Archivist
Posts: 1316
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Experimental very fast tape loading

Post by Symoon » Tue May 22, 2018 10:12 pm

I'm currently working at reducing the loader's loading time. It's about 1.1 second and this is a penalty for multipart programs, expecially if they're short.
I hope I can reduce it to something like 0.9 seconds (or better?), by structuring the code differently.

User avatar
Symoon
Archivist
Posts: 1316
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Experimental very fast tape loading

Post by Symoon » Thu May 24, 2018 12:10 pm

Questions for you guys.

For the price of 0,002 seconds of additional loading time ( :lol: ), I think I can fix (in Novalight) the ugly HIRES Loading bug from ROM 1.0, that displays "Loading" in the middle of a HIRES screen being loaded.

The question is: should I keep this bug, being typical of the ROM 1.0 glamour, or do you prefer it to be fixed?
(take into consideration that HIRES loading screens remain displayed for only a few seconds now ;) )

User avatar
Chema
Game master
Posts: 2201
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: Experimental very fast tape loading

Post by Chema » Thu May 24, 2018 1:25 pm

Kill the bug!!!

:)

Hey, I just realized I completely forgot about checking the tap you sent me! Sorry, sorry, sorry... I'll do it ASAP.

User avatar
Symoon
Archivist
Posts: 1316
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Experimental very fast tape loading

Post by Symoon » Thu May 24, 2018 3:05 pm

Chema wrote:
Thu May 24, 2018 1:25 pm
Hey, I just realized I completely forgot about checking the tap you sent me! Sorry, sorry, sorry... I'll do it ASAP.
No problem ;) Hope it works for you. Tested it fine on 90% of my Oric-1 and Atmos (10 machines, 1 fail).

BTW, I realise the idea of killing the HIRES Loading bug is not so useful...
I explain: even if Novalight prevents the line from being altered and erased leaving a dark line, Novalight is loaded first by... A standard CLOAD""! So in case of a loading screen followed by the main program, the next CLOAD will of course call the ROM bug and alter the HIRES screen anyway.
To sum it up: useful to load a screen, but useless if it is immediately followed by another CLOAD. Will try it anyway!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest