Oric-1 Sound Mod HELP !

This is the right place to discuss on how to implement hardware vsync, adding a VIA or AY chipset, puting multiple roms, or how to design a new flash expansion card.
Post Reply
User avatar
RoboFruit
Private
Posts: 7
Joined: Sat Nov 10, 2018 5:11 pm
Location: U.K
Contact:

Oric-1 Sound Mod HELP !

Post by RoboFruit » Mon Feb 04, 2019 12:19 am

So I did this sound mod quite some time ago and it worked http://www.48katmos.freeuk.com/soundmod.pdf.

When I recently had to dismantle my Oric-1 to repair the keyboard multiplexer I de-soldered and then put everything back together but thought it would be good to add an RCA socket rather than having the audio lead directly soldered to the switch. To my utter bemusement however when I plugged everything back in it didn't work. I can get sound to the internal speaker fine but switching to the external (speaker is in my 1084 monitor), I get nothing, nadda, not a thing.

I have not used a pot in my circuit, instead it looks like this...

Image

This is a picture of my mb with the wire traces...

Image

The only change I have made is to add a socket rather than having the lead going directly from the switch to the monitor via a wired RCA connection. I wonder if this has caused the issue but I have checked the connections and they are all good. What am I missing?

User avatar
iss
Squad Leader
Posts: 745
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: Oric-1 Sound Mod HELP !

Post by iss » Mon Feb 04, 2019 1:41 am

32034228207_89764a891d_z.jpg
1. Are the colors of the wires as on picture?
2. Check if the switch makes good connection in both positions
3. Take new picture with the RCA socket and the switch included....

User avatar
RoboFruit
Private
Posts: 7
Joined: Sat Nov 10, 2018 5:11 pm
Location: U.K
Contact:

Re: Oric-1 Sound Mod HELP !

Post by RoboFruit » Mon Feb 04, 2019 11:22 pm

Hi,

Yes that colouring is correct. I will do some more testing.

User avatar
Voyageur
Private
Posts: 6
Joined: Thu Oct 18, 2018 8:25 am
Location: Sydney

Re: Oric-1 Sound Mod HELP !

Post by Voyageur » Sat Feb 09, 2019 10:02 am

Hi,
could you connect a speaker on your RCA plug, something like 8 ohm/half or 1 Watt ?
Just to hear (or not) any sound ?
Oric Atmos : a new life !

User avatar
Voyageur
Private
Posts: 6
Joined: Thu Oct 18, 2018 8:25 am
Location: Sydney

Re: Oric-1 Sound Mod HELP !

Post by Voyageur » Sun Feb 10, 2019 5:57 am

And also, because I can't see it, did you cut the track on the Oric board between the red and the grey wires ?
Oric Atmos : a new life !

Post Reply