The big Oric ULA Database

In this forum you can write about anything that does not fit in other forums.
This includes generic Oric talkings and things that are totaly unrelated but want to share with people here :)
User avatar
iss
Squad Leader
Posts: 854
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: The big Oric ULA Database

Post by iss » Fri Jun 19, 2015 7:53 pm

Sorry to break above interesting off-topics but I need to share new facts about my ULA tests.
I'm very happy to say: please update ALL my entries in column 'does it work with Cumulus' to YES! :D
Now short details:
- all 6 ULA's are working on 2 Atmoses;
- 5 ULA's are working on Oric-1 48k, only the 'strange' revision CDI/8 (no letter) boots but Oric hangs;
- none works on Pravetz (yet...).
I need to confirm with more tests what I found as easy fix and will write during weekend the results ;).

User avatar
Chema
Game master
Posts: 2449
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: The big Oric ULA Database

Post by Chema » Fri Jun 19, 2015 9:47 pm

iss wrote:Sorry to break above interesting off-topics but I need to share new facts about my ULA tests.
:)

Great news! I look forward to reading your solution!

User avatar
Steve M
Flight Lieutenant
Posts: 492
Joined: Fri Mar 24, 2006 3:33 am
Location: Cumbria, UK
Contact:

Re: The big Oric ULA Database

Post by Steve M » Fri Jun 19, 2015 11:12 pm

I wonder of George (Jorodr) has considered this? He's intends building a new Oric.

User avatar
iss
Squad Leader
Posts: 854
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: The big Oric ULA Database

Post by iss » Sun Jun 21, 2015 12:12 am

Here is my successful story, I hope this info will be helpful for all Oric fans.
In short I found that Cumulus doesn't make good initial reset pulse to CPU -
the reason can be not enough time holding reset line low or not good TTL level
compatibility or the CPLD output can't discharge the famous capacitor C21.
Or maybe combination of all this possibilities...

Following this steps Cumulus works always on my 2 Atmoses with any of the 6 ULA's:
- connect Cumulus and insert good SD Card, formatted as fat32 with diskimages;
- power-on - don't pay attention to 'zebra' picture on the monitor;
- select any diskimage from Cumulus menu in virtual drive 'A:';
- now the trick - get metal tweezers and connect shortly pins 1 and 4 of the Cumulus power connector - your Oric should boot!

Interesting side effect: if you connect above pins shortly for second time - Oric resets in BASIC as there is no Cumulus.
I already soldered simple push button to the connector and everything works fine for me.

After having stable working Cumulus I made some additional tests, here are results and some conclusions:
1. Power supply - I bought (thanks Chema for advice) an universal PSU 3/5/6/7.5/9/12V and 1.5A.
Cumulus works perfect with 7.5V, 9V and 12V. Additionally I tested with all my other PSU's - everything works again.
Recommended is 7.5V - less heat in 7905.
2. 40 pin cable - I tested with no cable (as on picture in my previous post), with 2x long cables (40pin/80 wires) and
with 3x standard IDE cables - everything works!
Conclusion: type and length of the cables are actually not so critical.
3. PROM/EPROM - when I replace the standard BASIC PROM with EPROM - nothing works.
4. Pravetz can be fixed to work with Cumulus too - replace the resistor network RP1 (1kOhm) with 2.2 kOhms,
and C21 (100uF) with 1uF - this makes Pravetz to be an Atmos.
5. CPLD/PIC firmware - I programed the Xilinx CPLD with the sources from DF svn (of course fixed as previously discussed) - Cumulus works.
The same is with PIC sources. Conclusion: all sources are OK to be used in future Cumulus batches.

That's all!

User avatar
Dbug
Site Admin
Posts: 2930
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: The big Oric ULA Database

Post by Dbug » Sun Jun 21, 2015 7:59 am

iss wrote:- now the trick - get metal tweezers and connect shortly pins 1 and 4 of the Cumulus power connector - your Oric should boot!
Hmm,
that sounds like pressing the reset button on a microdisc?

It happened that my Atmos failed to boot when switching on, but then pressing the microdisc reset button would more often than not make the boot work.

Interesting :)

User avatar
Chema
Game master
Posts: 2449
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: The big Oric ULA Database

Post by Chema » Sun Jun 21, 2015 12:45 pm

This is interesting and a complete different problem to unreliable signals, I think. Glad you found a way to solve it! Maybe you could tweak the RESET signal duration in the CLPD sources or check it with an oscilloscope?

It would be nice too if you could tell the symptoms. I guess that you powered on and got a garbled screen and reset Oric did nothing?

User avatar
iss
Squad Leader
Posts: 854
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: The big Oric ULA Database

Post by iss » Sun Jun 21, 2015 1:01 pm

Yes, Chema, it's exactly as you said.
Power-on, garbage on screen and reset from Cumulus menu - does nothing, except change in noise coming from speaker.
I already increased the time in PIC sources, but nothing changes - until I connect pins 1 and 4, than Oric boots fine.
Else as I said above second connection of pins 1 and 4 makes nice reset in BASIC, but if I make first reset from Cumulus menu and than connect the pins - than Oric boots again in DOS :).

User avatar
ibisum
Wing Commander
Posts: 1095
Joined: Fri Apr 03, 2009 8:56 am

Re: The big Oric ULA Database

Post by ibisum » Sun Jun 21, 2015 2:15 pm

Ah, this is fascinating - so we could have a way to set the boot-up disk image?

User avatar
Chema
Game master
Posts: 2449
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: The big Oric ULA Database

Post by Chema » Sun Jun 21, 2015 2:43 pm

BTW what is the pin out of the cumulus power connector? I thought it was just 0 and 5 volt... The reset signal is in the other cable, isn't it?

User avatar
iss
Squad Leader
Posts: 854
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: The big Oric ULA Database

Post by iss » Sun Jun 21, 2015 3:45 pm

Pinout from original schematic:
power-con.png
And this is my mod :) :
power-con-mod.jpg

Godzil
Squad Leader
Posts: 763
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: The big Oric ULA Database

Post by Godzil » Mon Jun 22, 2015 2:48 pm

Interesting find

User avatar
coco.oric
Flight Lieutenant
Posts: 465
Joined: Tue Aug 11, 2009 9:50 am
Location: North of France
Contact:

Re: The big Oric ULA Database

Post by coco.oric » Mon Jun 22, 2015 7:20 pm

I agree, i'll test asap (may be next week)
coco.oric as DidierV, CEO Member
Image Image

Post Reply