Page 2 of 2

Posted: Thu Oct 23, 2008 8:23 am
by Chema


Posted: Wed Nov 05, 2008 9:35 pm
by Dbug
Chema wrote:Greetings.

Working on a possible radar display for the 3D game, I noticed the line drawer does NOT draw a line when origin and destination are the same.

Drying to draw a line from (24,24) to (24,24) I expected to see a dot at that position, but nothing was drawn.

Don't know if this is the desired behaviour or not...

Was it using the DrawLine or the DrawClippedLine routines ? What are the clipping parameters you used ?

I tried this:

Code: Select all

and that

Code: Select all


Both correctly displayed one single dot in (24,24).

Posted: Thu Nov 06, 2008 1:08 pm
by Chema
Dbug wrote: Both correctly displayed one single dot in (24,24).
Ok, I am completely embarssed. I don't know what I did or what I broke, but it is working now :oops:

I'd swear I made several tests and notice that behaviour. I did one today and it displayed the dot correctly, so I am completely confused. Most probably some kind of bug in my code that now has disappeared.

Sorry Dbug.

Posted: Thu Nov 06, 2008 6:16 pm
by Dbug
Don't feel bad :) After all there's a real bug somewhere, I still did not find why I have this +/- 1 pixel on the lines.

Posted: Thu Nov 06, 2008 6:24 pm
by Twilighte
I get that sometimes, bugs disappearing. I had one the other day with Wurlde whereupon you walked to a particular screen and it worked for about 30 seconds then crashed. I had left it for some time before i decided to try and fix it and strangely the bug was not happening anymore.

Sometimes i have found that the bug is when you have lots of source files (like Wurlde) and they all refer to a zeropage source file but i change this file and realise i must recompile all the other files again. In Wurlde now thats about 25 recompilations! :P

Posted: Thu Nov 06, 2008 7:09 pm
by Dbug
Which is why I rebuild everything all the time on the Oric :)
This way, no surprises :)