OSDK 0.20

Questions, bug reports, features requests, ... about the Oric Software Development Kit. Please indicate clearly in the title the related element (OSDK for generic questions, PictConv, FilePack, XA, Euphoric, etc...) to make it easy to locate messages.

Post Reply
User avatar
Dbug
Site Admin
Posts: 2360
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

OSDK 0.20

Post by Dbug » Mon Apr 09, 2012 6:27 pm

This update should please Xeron, but also people having performances issues on Windows 7 and Vista.

Version 0.20 - April the 8th 2012
- Oricutron 0.9 is now used by default instead of Euphoric, you can set OSDKEMUL to choose between EUPHORIC and ORICUTRON.

This is correct. I did not change anything else, this version is totally identically to the OSDK 0.19, all I did was to add Oricutron (Euphoric is still present) which allows us to handle three situations:
- Euphoric
- Euphoric through DosBox
- Oricutron

The first scenario works for people using Windows 98, kind of work on Windows XP, and totally does not work on Windows 2000, Windows Vista or Windows 7.
The second scenario works for about everybody, except that using Euphoric through DosBox makes the performance drop quite a lot, which can be a problem for people using old machines.
The third situation is optimal, because it brings us a native Windows 32 application, which runs nicely on all version of Windows, from Windows 95 to Windows 7, and from 32 bit to 64 bit setups.

In order to exploit this new system, you need to do a minor change to your osdk_execute.bat files, instead of calling %OSDK%\Euphoric\osdk_euphoric.bat you need to call %OSDK%\bin\execute.bat.

The original batch file is still there, so it will not stop your code to work, just that it will still call Euphoric.

If this version 0.20 works nicely, I will try to update the other components (like Old2MFM, Tap2CD, etc...) which are not Windows 7 friendly, so hopefully at some point the whole tool-chain will be usable on recent 64 bit windows.


You can get this version 0.20 here:
http://osdk.defence-force.org/files/osdk_0_20.zip

Give me feedback please, I need to know if I did not break anything.

I strongly advice you to install it on the side of the version your already use, just change your OSDK variable to point to the new folder, and if anything happens to not work, please signal the issue here, and continue to use your previous version instead.

Thanks !

User avatar
coco.oric
Flight Lieutenant
Posts: 425
Joined: Tue Aug 11, 2009 9:50 am
Location: North of France
Contact:

Re: OSDK 0.20

Post by coco.oric » Tue Apr 10, 2012 6:24 am

Thanks for it.
I'll update my config.
coco.oric as DidierV, CEO Member
Image Image

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Re: OSDK 0.20

Post by Xeron » Sun Apr 15, 2012 9:47 pm

Very cool! Good work, dbug! :-)

User avatar
Algarbi
Pilot Officer
Posts: 114
Joined: Thu Mar 19, 2009 10:47 pm

Re: OSDK 0.20

Post by Algarbi » Sun Apr 15, 2012 9:56 pm

Thank you :)

User avatar
Chema
Game master
Posts: 2035
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: OSDK 0.20

Post by Chema » Mon Apr 16, 2012 7:25 pm

Hi Dbug...

Just made a first quick test of OSDK 0.20. It compiles Skool Daze smoothly and correctly. Disk-based tools still give me problems under win64 (tap2dsk and old2mfm are called). Changed the make.bat to call dsktool and it worked.

Also when selecting Oricutron to execute the compiled file, it fails as it does not have the roms folder and the image folder is empty. Copied all the folders I have in Oricutron there, and I made it work...

Strange those folders are missing...

Cheers

User avatar
Dbug
Site Admin
Posts: 2360
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: OSDK 0.20

Post by Dbug » Mon Apr 16, 2012 7:54 pm

Chema wrote:Hi Dbug...

Just made a first quick test of OSDK 0.20. It compiles Skool Daze smoothly and correctly. Disk-based tools still give me problems under win64 (tap2dsk and old2mfm are called). Changed the make.bat to call dsktool and it worked.

Also when selecting Oricutron to execute the compiled file, it fails as it does not have the roms folder and the image folder is empty. Copied all the folders I have in Oricutron there, and I made it work...

Strange those folders are missing...

Cheers
Not strange, I removed them on purpose because I don't want to duplicate stuff in the OSDK. The ROM folder is one level up and shared with Euphoric, the image folder is not necessary. Now I did not check if disk configuration worked, only tape based stuff. Guess I need to check that.

About the old tools, well I sent a mail to Fabrice asking about native windows versions and got no answer so far.

User avatar
Chema
Game master
Posts: 2035
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: OSDK 0.20

Post by Chema » Tue Apr 17, 2012 10:10 am

Well Oricutron failed with two errors: not finding the ROM folder and not finding the IMAGES (the directory was empty). And I first tried with Skool Daze, so it is not related to a disk configuration.

If I have time I will make further testing trying to isolate the issue.

Cheers.

User avatar
Chema
Game master
Posts: 2035
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: OSDK 0.20

Post by Chema » Tue Apr 17, 2012 6:11 pm

Confirmed here, Dbug. It seems the images folder must exist (though the roms folder in the parent directory shared with Euphoric works). I get this error:
Unable to open 'roms\jasmin.rom'
Unable to open 'images\statusbar.bmp'
Not sure why it complains about the jasmin.rom file being missing, because it is there... maybe an error in the config file? :?

User avatar
Dbug
Site Admin
Posts: 2360
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: OSDK 0.20

Post by Dbug » Tue Apr 17, 2012 8:17 pm

Apparently I did a mistake when I packaged the version.
Believe me it worked, but since I test my version it creates TEMP and BUILD folders, so I need to cleanup, so probably I did something wrong there.

So what I fixed so far:
- Added the missing content of the image folder
- Fixed the bin/execute.bat to make it remember the starting directory (signaled by Woodmaster)

I tried all my samples, they all run fine, don't signal any problem with the roms, I checked with Skool Daze on the SVN, it's working well (just used one of the osdk_execute.bat from the %osdk%/sample folder)

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests