Page 1 of 1

SedOric-3 and INIT command

Posted: Wed Aug 08, 2018 12:12 am
by iss
This is my recent Oric-toy configuration:
mypic.jpg
It includes:
- Oric Atmos
- Original Microdisc controller
- Drive A: Gotek floppy emulator with OLED and buzzer mods (I will post more info in separated thread about it).
- Drive B: 3-inch double-sided drive, max 42 tracks.

Everything works perfect, but I found something strange with INIT command.
I boot from drive A and want to format the disk in drive B, so I type the command: INITB,17,42,D
The formatting starts fine, but the drive B is NOT always re-calibrated i.e. the magnetic head is NOT on track 00 and as result the command fails. :(

So, my questions are:
Is this behavior of INIT command already known or it's bug?
Is there a standard way to force drive re-calibration?
Or maybe I do something wrong?

Below is my temporary solution - redrive - small program, Atmos only,
which makes drive re-calibration using FDC1793 command restore.
The attached archive contains DSK, TAP and source! ;).

Any comments are highly appreciated !

Re: SedOric-3 and INIT command

Posted: Wed Aug 08, 2018 5:13 pm
by Dbug
No idea, I guess it's something André Cheramy of the CEO would know about.

Re: SedOric-3 and INIT command

Posted: Wed Aug 08, 2018 7:02 pm
by Chema
Very nice configuration! Does the bug also happen with older versions of Sedoric?

Re: SedOric-3 and INIT command

Posted: Thu Aug 09, 2018 7:47 pm
by coco.oric
Uh, i'm not an expert but traduce your interrogation in the mag.
May be André or somebody else will be able to solve it