Connectivity problems (again)

In this forum you can write about anything that does not fit in other forums.
This includes generic Oric talkings and things that are totaly unrelated but want to share with people here :)
User avatar
Symoon
Archivist
Posts: 1848
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon » Tue Jan 21, 2020 6:14 am

Chema wrote:
Tue Jan 21, 2020 1:48 am
Again...
"In total there are 224 users online :: 1 registered, 0 hidden and 223 guests (based on users active over the past 5 minutes)
Most users ever online was 350 on Mon Jan 20, 2020 11:31 pm"
I noticed a few timeouts recently, but nothing alarming as it could be any usual network mistake (only 2 or 3 in a week I'd say).

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Tue Jan 21, 2020 8:19 am

I guess I could still restart the server, see if that helps.

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Tue Jan 21, 2020 9:26 am

I applied all the pending updates and restarted the server.

User avatar
Symoon
Archivist
Posts: 1848
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon » Sat Mar 07, 2020 6:15 pm

Hi,

Sorry about that, but reporting a few slowdowns in the past few days, and 5 or 6 timeouts today, especially when posting.

User avatar
mikeb
Flying Officer
Posts: 172
Joined: Wed Sep 05, 2018 8:03 pm
Location: West Midlands, UK
Contact:

Re: Connectivity problems (again)

Post by mikeb » Sat Mar 07, 2020 6:28 pm

Agreed -- also from UK just now. Forum is showing 1 reg'd user (me) and 253 guests!!

Code: Select all

 While trying to retrieve the URL: http://forum.defence-force.org/index.php

The following error was encountered:

    Connection to 37.191.243.240 Failed 

The system returned:

    (110) Connection timed out

The remote host or network may be down. Please try the request again. 

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Sat Mar 07, 2020 7:05 pm

Ok, I'll restart the server tomorrow morning, since apparently that helped the few last times.

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Sun Mar 08, 2020 9:22 am

I installed the latest updates, and rebooted the server, is everything fine?

User avatar
Symoon
Archivist
Posts: 1848
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon » Sun Mar 08, 2020 9:54 am

Thanks. Still loads of "users" this morning (around 225), but no timeout after 5 minutes usage.

EDIT: I spoke too fast :( . Still slowdowns, and two timeouts trying to access this post to edit it.

User avatar
Symoon
Archivist
Posts: 1848
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon » Sun Mar 22, 2020 8:45 am

Sorry to report bad news once again...
For the past 2-3 days, about 33% of my requests to the forum fell in timeout. I waited a bit to see if anyone would report problems - as nobody did, I thought maybe with the pandemic, my connection was slowed down. But this morning it took me five attempts to reach the forum, so here I am again :-/ (that being said, I got 4 successful consecutive clics to post this message afterwards!)

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Sun Mar 22, 2020 9:28 am

I'm really sorry about that, I checked the logs, I can see indeed there are a bunch of timeouts now and then, but it's not clear what happens.

Next time it happens, could you do some quick check for me: I read somewhere that this could be PHP related, and most of the new parts of the site are in PHP (the forum, osdk, etc...) could you check if the old site also has issues?

http://www.defence-force.org/index_old.htm

Thanks!

User avatar
Symoon
Archivist
Posts: 1848
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Connectivity problems (again)

Post by Symoon » Sun Mar 22, 2020 10:37 am

We'll find out some day ;)
I clicked on the link to the old index, got two timeouts before reaching it. Once there, got 1 click OK, and the next one: timeout.
So it's apparently not PHP related, unless for some reason PHP uses all your bandwidth.

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Sun Mar 22, 2020 12:44 pm

Thanks for checking :)

User avatar
mikeb
Flying Officer
Posts: 172
Joined: Wed Sep 05, 2018 8:03 pm
Location: West Midlands, UK
Contact:

Re: Connectivity problems (again)

Post by mikeb » Mon Mar 23, 2020 8:19 am

Symoon wrote:
Sun Mar 22, 2020 8:45 am
I waited a bit to see if anyone would report problems - as nobody did,
....

t took me five attempts to reach the forum, so here I am again
I would have posted, but it took so many attempts to try and *read* the forum up to date and post a reply (put it on the copy/paste buffer just before hitting "submit" in case it gets eaten!), that I ran out of will to fight it :)

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Mon Mar 23, 2020 9:19 am

I checked the Apache error log, there are some php warnings about one of the test blogs and also DokuWiki.
I'm going to try to eliminate the parameters one by one, monitor the error log, and see if I can fix any of them, possibly that would help :-/

User avatar
Dbug
Site Admin
Posts: 3210
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Connectivity problems (again)

Post by Dbug » Mon Mar 23, 2020 2:50 pm

Most of the errors now in the logs are related to Doku Wiki, I will need to update it, that may temporarily break the Wiki.

Post Reply