Cumulus Issues

In this forum you can write about anything that does not fit in other forums.
This includes generic Oric talkings and things that are totaly unrelated but want to share with people here :)
User avatar
Chema
Game master
Posts: 1957
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: Cumulus Issues

Post by Chema » Tue Jun 09, 2015 11:14 pm

So we have 5 cases in which a 7C is not working correctly and 2 in which an 8F does.

(My 7C works almost, with some issues, solved when adding an amplibus,a s you know)

It could be interesting to swap the working ULA and the non working and see if things change.

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Wed Jun 10, 2015 10:20 am

I've created a google form to help create a ULA database:

https://docs.google.com/forms/d/1v_F0rq ... =send_form



The generated spreadsheet can be see here: https://docs.google.com/spreadsheets/d/ ... sp=sharing

The Name/Nickname is only to identify who has incompatible/nonworking ULA.

Dom, I've already entered yours ULA in the DB ;)

User avatar
Steve M
Flight Lieutenant
Posts: 386
Joined: Fri Mar 24, 2006 3:33 am
Location: Cumbria, UK
Contact:

Re: Cumulus Issues

Post by Steve M » Thu Jun 18, 2015 12:12 pm

Reading through some documents I found a letter where someone talks about an expansion similar to Amplibus that allows for three levels of amplification and has some other useful things like a reset button.
I have found details for the expansion and will post it in the hardware section. I think it is from ThéOric and is called Interface Microdisc.
It says it solves the problem of tapes not loading when a peripheral is attached so I 'm interested in trying this to see if it allows BDDISK to work.

Anyone tried this with the Cumulus ?

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Fri Jun 19, 2015 12:10 pm

I don't this that would help, not even sure that really does something at that time to have 3 buffer in parallel like this

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Sun Jul 19, 2015 6:49 pm

Argggg

That's absolutely normal that we have so much problem with the Oric...


Look at these signals taken on my Oric Atmos with nothing connected:
Phi2: Image
A12: Image
D7Image
A15: Image

I would say that's nearly a miracle that this computer is working :D

User avatar
Steve M
Flight Lieutenant
Posts: 386
Joined: Fri Mar 24, 2006 3:33 am
Location: Cumbria, UK
Contact:

Re: Cumulus Issues

Post by Steve M » Sun Jul 19, 2015 10:58 pm

It's alive !!!

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Wed Jul 22, 2015 3:44 pm

By the way, I will try shortly to provide an update for the Cumulus firmware with a longuer reset period to see it what has been found in, can't remember the thread, that a longer reset pulse may solve.

I will need to guineas pig for the test, I hope to not break any working cumuluse, I have some problem on mine :/ (can't get the was working SD to work currently..)

User avatar
iss
Flight Lieutenant
Posts: 458
Joined: Sat Apr 03, 2010 5:43 pm
Location: Bulgaria
Contact:

Re: Cumulus Issues

Post by iss » Thu Jul 23, 2015 8:23 am

As I previously wrote, we (jorodr and me) have 2 Cumuluses - both were not working.
I fixed both of them: the first one was with everything burned - I changed all chips and display and it works absolutely perfect!
The second one works very good too not counting the reset problem, which I fixed with simple button - the real problem here is that
the output driver in the Xilinx is broken, but for me it's not worth to replace the chip now.

Else, I verified and can tell that all signals are properly generated (including reset).
Yes, MAP can be optimized to be more close to the specification timings, but this will solve just very rare cases and requires Xilinx reprogramming.

After I analyzed every single detail of the hardware and firmware (pic and xilinx), I found 3 critical problems with current Cumulus - they can't be solved with current hardware.
Now I do some final tests on my 'secret' prototype and I hope in a week to announce something interesting for Oric community... :wink:

User avatar
Dbug
Site Admin
Posts: 2314
Joined: Fri Jan 06, 2006 10:00 pm
Location: Oslo, Norway
Contact:

Re: Cumulus Issues

Post by Dbug » Thu Jul 23, 2015 8:29 am

iss wrote:After I analyzed every single detail of the hardware and firmware (pic and xilinx), I found 3 critical problems with current Cumulus - they can't be solved with current hardware.
Now I do some final tests on my 'secret' prototype and I hope in a week to announce something interesting for Oric community... :wink:
Would be interesting to add these informations to the SVN documents for Cumulus, and eventually put there a revised version with the problems fixed.
Looking forward for your announcement :)

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Fri Mar 18, 2016 8:35 pm

For all of you who have a problem with an oric that does not like the Cumulus, could you check the reference of IC21?

It's the leftmost chip on the row of three just on top of the DRAM

The reference should something like 74xx04, what are the two XX for you?

User avatar
Symoon
Archivist
Posts: 1077
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Cumulus Issues

Post by Symoon » Sat Mar 19, 2016 9:52 pm

Godzil wrote:For all of you who have a problem with an oric that does not like the Cumulus, could you check the reference of IC21?
It's the leftmost chip on the row of three just on top of the DRAM
The reference should something like 74xx04, what are the two XX for you?
Here's for two of mine:

Computer ; serial n° ; IC21 ; ULA ; problem with Cumulus
Oric-1 ; 34187 ; DM74LS04N ; CDI-8B 8309 ; Random garbage on screen, characters set affected, hangs at system disc request
Atmos ; 287222 ; DM74LS04N ; CDI 9F 8419 ; Random garbage appearing little by little, sometimes boots with errors (Syntax Error loop).

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Sun Mar 20, 2016 1:18 am

Question con, si tu appuis sur le clavier tu entends les bips classiques?

User avatar
Symoon
Archivist
Posts: 1077
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Cumulus Issues

Post by Symoon » Sun Mar 20, 2016 10:34 am

Godzil wrote:Question con, si tu appuis sur le clavier tu entends les bips classiques?
Oui sans Cumulus, avec Cumulus alors qu'ils crashent, faudrait que je reteste mais j'en doute...

Without Cumulus yes, the computers run fine.
With Cumulus while computers are crashed, I'd need to test again, but I doubt the keyboard is working...

Godzil
Squad Leader
Posts: 754
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Cumulus Issues

Post by Godzil » Sun Mar 20, 2016 5:38 pm

I ask that (about he key click) because on the Atmos that I received from Steve M, it does not boot correctly with a cumulus attached, but the keyboard still makes its usual noises. I haven't had a screen attached, but I know it wasn't booting because I always use a demo like pushing the envelope because it make some loud noise once started :D

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest