Oriculator (WIP)

Comments, problems, suggestions about Oric emulators (Euphoric, Mess, Amoric, etc...) it's the right place to ask. And don't hesitate to give your tips and tricks that help using these emulations in the best possible way on your favorite operating system.
User avatar
kamelito
Flying Officer
Posts: 182
Joined: Sun Jan 08, 2006 6:34 pm
Location: Nantes, France

OSX

Post by kamelito » Wed Jul 22, 2009 11:02 pm

Hi,

I've compiled your emulator under OSX but it failed to load the rom. It is due to the fact that fopen() does not work on OSX like on Unix for example.
I found a way of handling this issue but didn't get the time to make it work. (I used xcode not the makefile)
When Oriculator don't find the rom it crash under OSX.(don't know about windows)

Kamel
Xeron wrote:I've added a memory watch window to the debugger.

I've also refactored and commented parts of the code.

There is a WIP snapshot build in the download section of the google code page, if anyone wants to try it out. It includes disk support, but don't expect it to work, it is still hopelessly broken.

BTW, if anyone wants commit access to the SVN to help out with development, let me know. You need a google account (not necessarily a gmail account).
/kml
skype pseudo : kamelitoloveless

User avatar
kamelito
Flying Officer
Posts: 182
Joined: Sun Jan 08, 2006 6:34 pm
Location: Nantes, France

Re: OSX EXC_BAD_ACCESS

Post by kamelito » Sat Jul 25, 2009 12:46 pm

When running Oriculator from Xcode I got a EXC_BAD_ACCESS from GDB

Line :
ay->envpos++; (file 8912.c)

ay value : 0xbfffe770
bmode 0 '\0'
creg 0 '\0'

envpos : -1073747911
envtab : 0x1c180 (\x0f\x0e\r\f\v\n\t\b\a\x06\x05\x04\x03\x02\x01)
*entav : 15 '\017'

The crash is related to the fact that the envpos is negative, if I set the value to 0 it work but when I type basic command I've a noise. (ay->envpos=0).
As I don't really know anything about 8192 AY emulation I can't do more than that.

Kamel
kamelito wrote:Hi,

I've compiled your emulator under OSX but it failed to load the rom. It is due to the fact that fopen() does not work on OSX like on Unix for example.
I found a way of handling this issue but didn't get the time to make it work. (I used xcode not the makefile)
When Oriculator don't find the rom it crash under OSX.(don't know about windows)

Kamel
Xeron wrote:I've added a memory watch window to the debugger.

I've also refactored and commented parts of the code.

There is a WIP snapshot build in the download section of the google code page, if anyone wants to try it out. It includes disk support, but don't expect it to work, it is still hopelessly broken.

BTW, if anyone wants commit access to the SVN to help out with development, let me know. You need a google account (not necessarily a gmail account).
/kml
skype pseudo : kamelitoloveless

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Sun Jul 26, 2009 9:13 pm

Ahh! It was a straightforward uninitialised variable bug. It actually solves a mystery for me; sometimes when oriculator started i got random noise until the first "real" oric noise. Do an SVN update and recompile. Thanks for the info!

BTW, if you have a google account, i'll give you commit access so you can commit OSX changes, if you like.

User avatar
kamelito
Flying Officer
Posts: 182
Joined: Sun Jan 08, 2006 6:34 pm
Location: Nantes, France

OS X build (10.5 univesal)

Post by kamelito » Sun Jul 26, 2009 11:43 pm

Hi,

I'm not an expert but may I suggest that you use stricter compiler settings for GCC it may have pointed out this error, but its frustrating too...
With the fix you've done it work now under OS X but I still have the noise before I hit a key that trigger a keyboard sound that fix the issue.

I've made a zip file containing the OSX version, if someone do have OS X please test it to see if it work. As I said fopen() do not work the same way under OS X so it might not find the roms.

Thanks for your emulator.

link : http://kamelito.ifrance.com/

Regards
Kamel
Xeron wrote:Ahh! It was a straightforward uninitialised variable bug. It actually solves a mystery for me; sometimes when oriculator started i got random noise until the first "real" oric noise. Do an SVN update and recompile. Thanks for the info!

BTW, if you have a google account, i'll give you commit access so you can commit OSX changes, if you like.
I don't but I maybe should :)
/kml
skype pseudo : kamelitoloveless

User avatar
kamelito
Flying Officer
Posts: 182
Joined: Sun Jan 08, 2006 6:34 pm
Location: Nantes, France

Re: OS X build (10.5 univesal)

Post by kamelito » Tue Jul 28, 2009 8:58 pm

Hi Xeron,

I have a google account, I lost my password but I'd like to upload the compiled OSX version of Oriculator at google code repository.

Can you grant me acccess please ?
Regards
Kamel
Xeron wrote:Ahh! It was a straightforward uninitialised variable bug. It actually solves a mystery for me; sometimes when oriculator started i got random noise until the first "real" oric noise. Do an SVN update and recompile. Thanks for the info!

BTW, if you have a google account, i'll give you commit access so you can commit OSX changes, if you like.
I don't but I maybe should :)[/quote]
/kml
skype pseudo : kamelitoloveless

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Wed Jul 29, 2009 7:36 am

Sure. E-mail me your google account name to pete "at" petergordon "dot" org "dot" uk, please.

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Thu Jul 30, 2009 12:13 pm

Well, i haven't uploaded a binary yet, but the code in the repositry now supports symbols. When you insert a tape image, if there is a "symbols" file in the same directory, it will (optionally) automatically load those symbols.

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Thu Jul 30, 2009 10:46 pm

I've uploaded a binary of the current version (SVNr12) to the download page here.

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Mon Aug 10, 2009 12:00 pm

Has anyone tried the new debugger features (memwatch, symbols) yet? Opinions? Suggestions?

User avatar
Twilighte
Game master
Posts: 819
Joined: Sat Jan 07, 2006 12:07 am
Location: Luton, UK
Contact:

Post by Twilighte » Tue Aug 11, 2009 10:23 am

Thinking about it i'll try it shortly because IM is tape based and the debugging features of your emu appear to beat Euphoric by far.

Also having the ability to see the video output at the same time as debugging is awesome! :shock:

User avatar
Twilighte
Game master
Posts: 819
Joined: Sat Jan 07, 2006 12:07 am
Location: Luton, UK
Contact:

Post by Twilighte » Tue Aug 11, 2009 8:58 pm

I just had a go at Oriculator and it worked very well.
It would be really cool if it were possible to add a memory breakpoint, ie. that the emulator would return to debugger mode when a specific memory location contains a specific value. This way we could trap alot more bugs :)

What would also be very useful would be a monitor command to continue until breakpoint (updating any screen activity in top left). Just like Euphorics F5 key.

But i think in general i will keep with Euphoric and dosbox until this is taken a tad further, not because it offers less but because i am so familiar with euphoric.

User avatar
ibisum
Squad Leader
Posts: 873
Joined: Fri Apr 03, 2009 8:56 am

Post by ibisum » Tue Aug 11, 2009 11:31 pm

Nevertheless, as both projects mature, it would be great to see them continue to work well with each other .. I think both IM and Oriculator are a perfect fit for each other, frankly!

User avatar
Symoon
Archivist
Posts: 1169
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Post by Symoon » Sat Aug 15, 2009 12:31 pm

A few things you might already know, but anyway:
- the SDL.dll is missing in the latest release (maybe it's supposed to be only in the original package, no idea)
- the memory watch in the debugger doesn't seem refreshed after a reset (from F1 menu)
- how do we do a simple reset, the one that was under the Oric ? ;-)
- is it possible to edit the RAM or send keys in the debugging mode?

Very nice work anyway ;-)

User avatar
Xeron
Emulation expert
Posts: 382
Joined: Sat Mar 07, 2009 5:18 pm
Contact:

Post by Xeron » Sat Aug 15, 2009 2:15 pm

- Missing DLL is an oversight.
- Reset from the F1 menu is a jump to ROM start. No memory is cleared.
- What does the reset button under the oric actually do?
- Neither of these are possible (yet) :-)

Brana
Flying Officer
Posts: 151
Joined: Fri Nov 30, 2007 8:30 pm
Contact:

Win98 compactibility?

Post by Brana » Sat Oct 10, 2009 2:09 pm

Have anyone tested it on Win98? :)

I have, and it loads the intial Oric screen, but then it "freezes" and does not respond to keyboard, not even to F1 key.

Perhaps this is not such a "big deal" for most of people now are running WinXP (it works fine on WinXP), but again - is it possible to consider the compactibility with Win98? (if you are interested for that?)

Best regards
Brana

Post Reply

Who is online

Users browsing this forum: ThomH and 4 guests