Euphoric restoration problem

Comments, problems, suggestions about Oric emulators (Euphoric, Mess, Amoric, etc...) it's the right place to ask. And don't hesitate to give your tips and tricks that help using these emulations in the best possible way on your favorite operating system.
Post Reply
User avatar
Hialmar
Flight Lieutenant
Posts: 318
Joined: Tue Mar 04, 2014 11:25 am
Location: Toulouse, France
Contact:

Euphoric restoration problem

Post by Hialmar » Tue Mar 04, 2014 11:38 am

Hi everyone,

My name is Patrice Torguet. I am from Toulouse, France.

I have an Oric Atmos but unfortunately it has a graphics problem (the sound works well though).

So I use Euphoric and other Oric emulators.

Recently I have found a bug with the restoration feature.

When I use "euphoric -r" to read a memory dump, euphoric loads the backup but then the keyboard isn't working anymore. The F1 and other function keys work though.

I have tried this on:
* Windows XP using the last version of Euphoric (1016);
* Mac OS X 10.9 using 3 versions of DosBox (0.70, 0.74 and 0.74-1 [looks like it is a Mac OS X specific version] - I thought it was related to it at the beginning) and two versions of Euphoric (1016 and 1015);
* Win7 x64 using DosBox 0.74 and Euphoric 1016.

I posted the problem on oric.org forums, Maximus checked it on his own Euphoric and had the same problem.
I have sent an e-mail to Fabrice (I know him from a very long time ago) to report the problem but I think it would be good if several people checked this problem.

I have a Dump available here if people want to check it:
http://torguet.net/Hialmar/Dump
Hialmar
CEO and Silicium member.

Godzil
Squad Leader
Posts: 755
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Euphoric restoration problem

Post by Godzil » Tue Mar 04, 2014 12:39 pm

When the keyboard is not working, does the "PASTE" feature work ?

User avatar
Hialmar
Flight Lieutenant
Posts: 318
Joined: Tue Mar 04, 2014 11:25 am
Location: Toulouse, France
Contact:

Re: Euphoric restoration problem

Post by Hialmar » Tue Mar 04, 2014 2:53 pm

I didn't even know there was such a feature in Euphoric.

How do you use it ?
Hialmar
CEO and Silicium member.

User avatar
peacer
Flight Lieutenant
Posts: 349
Joined: Wed Jun 09, 2010 9:23 pm
Location: Turkey
Contact:

Re: Euphoric restoration problem

Post by peacer » Tue Mar 04, 2014 3:02 pm

As far as I know only oricutron's last version has paste functionality.

Godzil
Squad Leader
Posts: 755
Joined: Sat May 21, 2011 7:21 pm
Location: Between UK and France
Contact:

Re: Euphoric restoration problem

Post by Godzil » Tue Mar 04, 2014 3:16 pm

Oups sorry, I misread the first post and tought you used Oricutron and not Eurphoric, please forget what I said :) (BTW, you should move to oricutron, euphoric is now a really old thing)

User avatar
Hialmar
Flight Lieutenant
Posts: 318
Joined: Tue Mar 04, 2014 11:25 am
Location: Toulouse, France
Contact:

Re: Euphoric restoration problem

Post by Hialmar » Tue Mar 04, 2014 3:26 pm

Well I think both emulators have their strengths and weaknesses.

Euphoric is most of the time faster.
Specifically when loading tapes.
Oricutron is so slow for this.
I plan to look at the code and try to make it faster.

And Euphoric is not old, the last version is dated from July of last year. Not that old in my opinion.

Oh and of course it is coded by Fabrice Francès who is the living god of Oric ;)
I know, I met him and worked at his workplace in Toulouse.
Hialmar
CEO and Silicium member.

User avatar
Hialmar
Flight Lieutenant
Posts: 318
Joined: Tue Mar 04, 2014 11:25 am
Location: Toulouse, France
Contact:

Re: Euphoric restoration problem

Post by Hialmar » Tue Mar 04, 2014 10:21 pm

I found an even older version of Euphoric (1007) and restoration works okay in this build.

So something happened to the feature between 1007 and 1015.

I don't have build between those to find out exactly which one broke it.
Hialmar
CEO and Silicium member.

User avatar
Symoon
Archivist
Posts: 1159
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Re: Euphoric restoration problem

Post by Symoon » Tue Mar 04, 2014 11:59 pm

Hialmar wrote:So something happened to the feature between 1007 and 1015.
Had a few more versions: 1009 still restarts fine, 1013 is keyboard-broken.

User avatar
Chema
Game master
Posts: 2029
Joined: Tue Jan 17, 2006 10:55 am
Location: Gijón, SPAIN
Contact:

Re: Euphoric restoration problem

Post by Chema » Wed Mar 05, 2014 11:56 am

mmm Fabrice added a more realistic emulation of the keyboard matrix behavior in the recent versions; something we found when making 1337 compatible with the Telestrat (yes he found something related to the keyboard and also a bug in the Telestrat disc hardware).

Maybe the changes had a side effect when restoring dumps? It is hard to say...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest