Tape conversion problem with Simulateur

Anything related to the tools Tap2Wav, Tap2CD, Tap2Dsk, Sedoric Disc Manager, Tape Header Creator, WriteDsk, and generaly speaking tools related to the management of Oric data files and devices.
Post Reply
artifexor
Private
Posts: 5
Joined: Sat Oct 15, 2011 4:15 pm
Location: Budapest, Hungary

Tape conversion problem with Simulateur

Post by artifexor » Sat Oct 15, 2011 4:26 pm

Hello!

I try to sample and convert Oric program Simulateur from original tape. Sample is sounds great but wavclean and wav2tap cannot convert. wavclean makes a strange sounding output and wav2tap makes a zero byte length tap file.

I tried to tap2wav and wav2tap Xenon1.tap and that was successful so those programs probably working great. tap2wav makes a totally different sounding wav file that mine. So I think the problem is somewhere in the wav file.

What I have to check or change for converting wav to tap?

Bye,
a

User avatar
kenneth
Flying Officer
Posts: 168
Joined: Fri Nov 26, 2010 9:11 pm
Location: France PdD
Contact:

Post by kenneth » Sat Oct 15, 2011 6:15 pm

Hello

you can do it like that (with my computer it works nice) :)

Run Audacity program settled on sampling mono 96000Hz ("another format" 8-bit unsigned Microsoft)

make "record" on Audacity (its computer micro set to "2" with "amplifier" activated micro)

on oric do csave "name"

Save sample as 96000 Hz

convert the sample in 44100hz to be recognized by wavclean

save it in"mono 44100Hz unsigned" (8-bit unsigned Microsoft format)

Edit the ".bat" file of wavclean to note the saved audio file.

run wavclean.bat

Open euploric and with f1 activate "tape recorder" and point to the file created by wavclean in

"TAPE"

make CLOAD""

good luck :D
Last edited by kenneth on Sat Oct 15, 2011 7:18 pm, edited 1 time in total.

artifexor
Private
Posts: 5
Joined: Sat Oct 15, 2011 4:15 pm
Location: Budapest, Hungary

Post by artifexor » Sat Oct 15, 2011 6:37 pm

kenneth wrote:you cant do it like that (with my computer it works nice) :)

Run Audacity program settled on sampling mono 96000Hz ("another format" 8-bit unsigned Microsoft)

make "record" on Audacity (its computer micro set to "2" with "amplifier" activated micro)
Merci beaucoup! 96 kHz? Looks too high to me.
kenneth wrote:on oric do csave "name"
Unfortunately I have no real Oric computer just a good old tape which I did not sell. Therefore I can only use tape recorder to play tape.
kenneth wrote:Save sample as 96000 Hz

convert the sample in 44100hz to be recognize by wavclean

save it in"mono 44100Hz unsigned" (8-bit unsigned Microsoft format)

Edit the ".bat" file of wavclean to note the saved audio file.

run wavclean.bat

Open euploric and with f1 activate "tape recorder" and point to the file created by wavclean in

"TAPE"

make CLOAD""

good luck :D
Thank you! I have tried to record with GoldWave and Wavosaur in 44.1 KHz now it's time to use Audacity.

User avatar
Symoon
Archivist
Posts: 1061
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Post by Symoon » Sat Oct 15, 2011 8:19 pm

Alternatively I can put it somewhere for download.
Made from the original tape, too.
Ah, if I had a clone (or two), it would be on Oric.org ;-)

User avatar
kenneth
Flying Officer
Posts: 168
Joined: Fri Nov 26, 2010 9:11 pm
Location: France PdD
Contact:

Post by kenneth » Sat Oct 15, 2011 8:42 pm

artifexor wrote:
Merci beaucoup!
на вашите услуги ! :D

artifexor
Private
Posts: 5
Joined: Sat Oct 15, 2011 4:15 pm
Location: Budapest, Hungary

Post by artifexor » Sun Oct 16, 2011 9:42 am

Symoon wrote:Alternatively I can put it somewhere for download.
Made from the original tape, too.
Ah, if I had a clone (or two), it would be on Oric.org ;-)
That would be amazing. I already upload mine in FLAC format but unsure about posting here or write a PM. I upload because someone might find out what is the problem with my recorded file.

User avatar
Symoon
Archivist
Posts: 1061
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Post by Symoon » Sun Oct 16, 2011 1:10 pm

artifexor wrote:
Symoon wrote:Alternatively I can put it somewhere for download.
Made from the original tape, too.
Ah, if I had a clone (or two), it would be on Oric.org ;-)
That would be amazing. I already upload mine in FLAC format but unsure about posting here or write a PM. I upload because someone might find out what is the problem with my recorded file.
Ok, get it there (temporary download, will remove it when it's OK):
http://mercenarysite.free.fr/oric/voloric.zip.

I'd be interested in your WAV file to let you know, maybe, what's wrong. Would it be possible to you to upload the WAV instead of FLAC ? (I have no Flac conversion tool and an almost full hard drive).
The ideal would be 44khz, 8 bits, and a single channl would be enough if it's just to check what can be wrong. Only thing that springs to mind is that your tape player may be running too fast or too slow.

artifexor
Private
Posts: 5
Joined: Sat Oct 15, 2011 4:15 pm
Location: Budapest, Hungary

Post by artifexor » Sun Oct 16, 2011 3:13 pm

Symoon wrote:Ok, get it there (temporary download, will remove it when it's OK):
http://mercenarysite.free.fr/oric/voloric.zip.
Downloaded, thank you.
Symoon wrote:I'd be interested in your WAV file to let you know, maybe, what's wrong. Would it be possible to you to upload the WAV instead of FLAC ? (I have no Flac conversion tool and an almost full hard drive).
The ideal would be 44khz, 8 bits, and a single channl would be enough if it's just to check what can be wrong. Only thing that springs to mind is that your tape player may be running too fast or too slow.
OK, uploaded the 23 MB WAV version. Here it is:
-- removed --

If you need the "original" stereo file just tell me. If I look the file in wave editor it seems ok but no success on convert. I have only an old walkman so that speed problem might happened indeed.
Last edited by artifexor on Sun Oct 16, 2011 8:07 pm, edited 2 times in total.

User avatar
Symoon
Archivist
Posts: 1061
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Post by Symoon » Sun Oct 16, 2011 4:08 pm

Thanks for the file.
Aha, that was easy : your recording is at slow speed (300 bauds), you know, you have to CLOAD"",S for it.

Wav2tap only works with fast speed recordings !
Once converted with Wavclean, did you try to CLOAD"",S your WAV file in Euphoric with the hardware tape (in the F1 menu screen). Loading operates here, but there are errors, which could be predictable when looking at the WAV signal quality (many parasites are visible in the 2nd half of your WAV file).

I don't think there is a converting tool for slow speed yet. I've been working on one for years, but encountered several problems (lack of spare time being the most boring !). Hope to finish it some day.

artifexor
Private
Posts: 5
Joined: Sat Oct 15, 2011 4:15 pm
Location: Budapest, Hungary

Post by artifexor » Sun Oct 16, 2011 6:20 pm

Symoon wrote:Thanks for the file.
Aha, that was easy : your recording is at slow speed (300 bauds), you know, you have to CLOAD"",S for it.

Wav2tap only works with fast speed recordings !
I see. Thanks for the clarifying. There is a text CLOAD "",S on tape label but I did not remember the slow mode but now it is OK. And that's why there is audible difference between Xenon1 and Simulateur wave file.
Symoon wrote:Once converted with Wavclean, did you try to CLOAD"",S your WAV file in Euphoric with the hardware tape (in the F1 menu screen). Loading operates here, but there are errors, which could be predictable when looking at the WAV signal quality (many parasites are visible in the 2nd half of your WAV file).
The tape is two sided so I will try the other side of tape.
Symoon wrote:I don't think there is a converting tool for slow speed yet. I've been working on one for years, but encountered several problems (lack of spare time being the most boring !). Hope to finish it some day.
I do not know what is the difference between slow and normal mode (except the loading time I think :-)

Made a new version and uploaded:
http://www.megaupload.com/?d=TPHSUV2U

After converting with wavclean successfully loaded into Euphoric. :-)

User avatar
Symoon
Archivist
Posts: 1061
Joined: Sat Jan 14, 2006 12:44 am
Location: Paris, France
Contact:

Post by Symoon » Mon Oct 17, 2011 10:38 pm

Happy end then ;)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest