Page 1 of 1

Anyone has init11.exe?

Posted: Fri Sep 17, 2010 7:32 pm
by ibisum
Hiya folks,

I'm spending my Friday evening trying to get some disks made for my new Telestrat, but try as I may, writedsk.exe gives me "Write Error" every time.

I've tried to format my HD-floppies (all I have) as 720k floppies (with tape over the HD hole to make it appear to be a DD disk) but I still get a write error from writedsk.exe. This is on an old Dell Inspiron 8200 laptop, which is the only machine in the house that still has a floppy drive, by the way. I tried "format a: /N:8 /T:80" as well (to get a 640k drive) but format (winXP) tells me that this operation is not supported by the drive ..

So it appears my last chance is to chase down this init11.exe program, which presumably does a lower-level format of the drives .. trouble is, I can't find it anywhere.

Anyone know where it might be located - perhaps in a French-named .zip file somewhere, or .. somewhere else? I'd really appreciate the help - I'm so close to actually experiencing disk-based Oric hacking this evening, I can taste it .. ;)

Posted: Fri Sep 17, 2010 7:53 pm
by Chema
Maybe I am saying something stupid, but did you try to execute writedsk under DOS (or win95)?

Maybe winXP is the reason for it failing?

Posted: Fri Sep 17, 2010 8:02 pm
by Dbug
I fear that only Dos/Win95/Win98 is going to work, but well, you can still try. I uploaded init11.exe there: ...

Good luck :)

Posted: Fri Sep 17, 2010 8:04 pm
by ibisum
I guess I'll try that next .. or is anyone aware how to make a 640k floppy under Linux (this machine can dual-boot to Linux too) ..

Geeze, all these old machines, and they're antiquated tech. I've got 3 boot USB disks on my keychain, heh heh ..

Posted: Fri Sep 17, 2010 8:06 pm
by ibisum
[duplicate post deleted]

Posted: Fri Sep 17, 2010 8:08 pm
by Dbug
The solution I used in the end was basically to create a bootable DOS disk, and use write DSK from there.

Typically I burnt all my DSK files on a cdrom, then used one of these floopy boot makers that creates a bootable ms dos disk with support for the cd rom using mscdex, then boot on dos and used writedsk to write a bunch of oric floppies :)

Now you have to know that some motheboard/floppy drive do not support double density disks at all, all that for the sake of cost reduction.

Posted: Sat Sep 18, 2010 1:38 am
by ibisum
Okay after much mucking around, I pretty much did the same thing .. created a boot floppy *specifically* for just being in DOS with CD-ROM access (man that was a blast as well!) and burned a CD with the .dsk files I want to play with.

Some observations:

1. init11.exe definitely does *something* with my drive/floppy combination, at least: when its run in a DOS BOX in WinXP. Under plain old DOS, it fails, as far as my faulty French can see .. but never mind, I do this part under WinXP, things grind along, and the floppy is no longer in Win/DOS land ..

2. I boot to the clean DOS disk, and now writedsk.exe doesn't work - but the write.exe that you included in the .zip file (thanks very much) - does work! It appears to just be a newer/better compiled (?) version of writedsk.exe anyway, so I go with it .. writedsk stratosed.dsk a: .. takes forever, does things twice (!) it seems, or "upper side/lower side", and well .. doesn't seem to complain. So this gives me confidence. However ..

3. I pop the newly minted floppy into the Telestrat, boot the system, and nothing happens. This is actually progress - my previous usage of the "Write Error" version (writedsk.exe used in WinXP) *hangs* the Telestrat, for some reason. But not so with the new one, made from DOS .. Telestrat boots as per usual, but .. doesn't seem to actually access the disk at all. No grinding of the floppy. And no StratoSed, like I've seen it in the emu's. Grr.

I give up for the evening - I can't sit there listening to the floppy write process much more tonight, but tomorrow I'll try a few other .dsk images, just in case I've managed to get a dud stratosed.dsk .. lets see if that works. Something for lunch-time hijinks, anyway ..

Sure has been fun with new Oric hardware in the house. :) Even the smell, though its decades old now, of the machine somehow brings me back, heh heh ..

Posted: Sat Sep 18, 2010 12:56 pm
by Dbug
I would suggest to try all that in emulator before trying for real:
- Setup euphoric with the exact set of cartridges you have
- Try to boot the DSK file on the emulator

Most probably if it does not work on the emulator it will not work on the real machine, and if it works on the emulator at least you know that your DSK file is working :)

Posted: Wed Sep 29, 2010 2:37 pm
by ibisum
The DSK files are working in the emulator (latest Oricutron, always built from the latest svn version) so I guess I just don't have a floppy drive that is capable of handling this right now .. seriously annoying, but okay. Time to go dumpster diving.

Posted: Wed Sep 29, 2010 9:40 pm
by Chema
Hope you solve it and can transfer disks to your telestrat soon...

So you will be able to test the soon-to-come 1337 new version with Telestrat support :)

Posted: Thu Sep 30, 2010 3:51 pm
by ibisum
If I get it resolved, I guarantee you that I'll be testing 1337 on Telestrat ASAP! :)